Next forum testing

Jeff's avatar

Hi friends... y'all have been a great help over the last two decades in helping me figure out how to make the forum work best. As much as I want to sell it (and haven't), I mostly enjoy the fact that it's software that I get to use with you to write about how RRR sucks. For some reason, I keep improving it. The last few years have all about performance, and I don't think I can make it much faster unless I spend more to run it on faster hardware. After years of not being sure how to improve the front end of it, that is, the part you interact with, I think I have a direction. I credit bupropion XL.

When I make changes, they are built and run on the internets on what's knowns as a continuous integration build. That build is here. Over the course of probably the rest of the year, I'll keep making improvements, a little at a time, and I'd love for you to make an account over there and mess with it when I call it out. No criticism is unwarranted. Be as brutal as you want. Someday, it's gonna be on this site. What you see is not likely final.

The first thing I'm trying to tackle is quote posting. For years, it's been backward. Someone pushes the "quote" button and then they have to trim back the stuff. On the build up there now, well, I'm gonna let you go nuts. Try and quote something in this thread and see what happens. Then before you submit, try and quote from another post.


Jeff - Editor - CoasterBuzz.com - My Blog - Phrazy

Vater's avatar

I forgot about that build, I used it to test linking to posts a while back. I need to remember to head over there and test stuff that isn't working before I mention it here.

I credit bupropion XL.

I took a couple of those for my hemorrhoids last week.

Vater's avatar

Holy balls, I dig the new post quoting.

> bupropion XL.

I'm a big fan too.


Tommytheduck's avatar

Jeff said:

Hi y'all I mostly enjoy the fact that I get to interact with, keep making improvements, mess with, Be brutal, and trim back nuts.

How's that?

Jeff's avatar

Lord Gonchar:

Yeah, this quote thing is so obvious, so much better and no one thought of it.

Here's the question though... if you quote a secondary post, it's not obvious that the quote was copied down since it doesn't scroll. What should the UI signal be for that? The selection clear, sure, but I'm not sure if that's enough.


Jeff - Editor - CoasterBuzz.com - My Blog - Phrazy

Vater's avatar

A popup that says "post quoted" or something that fades out after a couple seconds? Kind of like on sites like soundcloud, where you click the "Copy Link" link to share a file.

Lord Gonchar's avatar

I feel like the "select text" prompt disappearing is the confirmation and if it's not entirely clear the first time, if your users are like me (and God forbid, really) then they'll scroll down manually the first time they try it to see if it worked and it will make sense. Like a 'real world' tutorial. But that may just be me.

What I did notice is that without the scroll, it doesn't seem to be opening the reply box upon quoting. I seem to have to hit the "Post a Reply" to open the reply box and then go back up the thread and quote to fill the box (giggity!).


Jeff's avatar

Really? Try again. You should select text, press quote, and it should scroll to the text box with the quote. Subsequent select/quotes will not scroll, but the box is already open.


Jeff - Editor - CoasterBuzz.com - My Blog - Phrazy

Jeff's avatar

Of course it doesn't work in Safari. :shakesfist@apple:


Jeff - Editor - CoasterBuzz.com - My Blog - Phrazy

Raven-Phile's avatar

Interestingly enough, no matter what I try to post, it says my post is empty. I’m on iOS mobile

Lord Gonchar's avatar

Nevermind. Must have been a Chrome thing.

Closed and opened back up and we're good.


Jeff's avatar

Josh: Yeah, Safari. Scouring the Internets now for a workaround.

Does anyone actually use the plain text mode anymore? I mean, besides Dave? 😂


Jeff - Editor - CoasterBuzz.com - My Blog - Phrazy

Jeff's avatar

OK, works on Mac now, so try your iThings.


Jeff - Editor - CoasterBuzz.com - My Blog - Phrazy

Raven-Phile's avatar

Works on my iPad.

Lord Gonchar said:

Nevermind. Must have been a Chrome thing.

Closed and opened back up and we're good.

I had the same exact issue...also on Chrome.


Fever I really enjoy the Simpsons. It's just a shame that I am starting to LOOK like Homer.
Jeff's avatar

Caching has become a real problem with browsers, which is weird because we have more bandwidth than ever. You can beat it by changing the name or appending a query string, but you shouldn't have to.


Jeff - Editor - CoasterBuzz.com - My Blog - Phrazy

Vater's avatar

Speaking of caching, I'm guessing this is related but not sure. I've noticed on this site in the "recent" view, when a new post is made and the New Posts icon highlights automatically, clicking on that icon returns an error. Clicking back and then on the icon again works fine. I tried to test this on the build site, but the icon doesn't seem to highlight automatically, it requires refreshing the page (which I believe is how it used to work on this site).

Jeff's avatar

Weird, I can't repro and there aren't any errors with your name on it in the log. When you say "error," what do you see?


Jeff - Editor - CoasterBuzz.com - My Blog - Phrazy

Vater's avatar

I'll grab a screenshot next time it happens. It only happens when new posts show up while the browser is otherwise inactive.

You must be logged in to post

POP Forums - ©2022, POP World Media, LLC
Loading...