Wednesday, February 15, 2017 5:24 PM

I'm trying to edit an old post to include a hyperlink to a previous post on CoasterBuzz. From the old post, I click on the "Link" button under said post, then copy the URL from the address bar. When I paste the URL in the hyperlink pop-up, I confirm it's correct, then save the edited post. When I click the newly-added hyperlink, I get a "404 - Not found" error, because during the save, the URL magically changed. Seems to work on new posts, but not edited ones?** Not sure.

Here's what happens. I add a link that looks like this:

https://coasterbuzz.com/Forums/Topic/<topic_title_and_post_#>

Then I save and click the link, and it loses "Forums/" in the URL:

https://coasterbuzz.com/Topic/<topic_title_and_post_#>

When I go back to edit the link, it shows up like this in the pop-up:

.../.../Topic/<topic_title_and_post_#>

Saving it again makes no difference--still get the error. I've even deleted the second ".../" and replaced it by manually typing "Forums/", but then it looks like this:

https://coasterbuzz.com/Forums/Forums/Topic/<topic_title_and_post_#>

**I use Chrome...but to complicate things further, I just tried it in Firefox, and the hyperlink I created in a new post that worked in Chrome, doesn't work in Firefox. The URL navigates to:

https://coasterbuzz.com/Forums/<topic_title_and_post_#>

This time, "Forums" is there, but "Topic" is missing. :-/

Last edited by Vater, Wednesday, February 15, 2017 5:27 PM
+0
Wednesday, February 15, 2017 5:56 PM

That "URL Change" happens to me sometimes (using Chrome), but not all the time and for the life of me I can't figure out what the diffrence is.

+0
Wednesday, February 15, 2017 11:46 PM

I've seen it now and then too, but can't figure out consistently why. The text editor is an open source project I didn't write, so it's a black box to me.

That said, if you want to link to a specific post, don't use whatever is in the URL bar. Right click the "link" from the post and copy that link address (as opposed to the destination that it bounces you to). There are a couple of reasons for that. First, that URL will redirect you to the right place every time, even if posts were deleted, no matter what paged set of posts it falls on. Second, as moderators, the deleted posts never go away... we see them all inline with the rest, so if there are 25 posts, but 10 deleted, you see it on the second page, but for mods it's on the third.

+0
Thursday, February 16, 2017 1:05 PM

Well, that worked...once. I went to edit another post, copied the link address as you illustrated above, and it now throws a 404. It's maddening; there's seemingly no rhyme or reason for when it works or doesn't.

+0
Thursday, February 16, 2017 7:27 PM

Can you post a link to the post? I know... it's very possible you won't be able to. That's some chicken and egg **** right there.

+1Loading
Friday, February 17, 2017 12:15 AM

It'll probably let me post a link if I paste in the body instead of using the link tool: https://coasterbuzz.com/Forums/Topic/wdw-mk-to-offer-more-alcohol-o...ns-#941594

But go to that post and click the picture. That's what gives the error, but this is the post it's supposed to link to: https://coasterbuzz.com/Forums/PostLink/941432

+0
Friday, February 17, 2017 11:16 AM

OK, so it's dropping the Forums part of the URL. That's super weird.

You can get around that by using the URL without the host, so basically the starting slash and everything after, like:

/Forums/PostLink/942626 (trying with a link button paste and partial path)

Last edited by Jeff, Friday, February 17, 2017 11:16 AM
+0
Friday, February 17, 2017 2:46 PM

Doesn't work. It's still losing the "Forums" part no matter what I do. Just cleared all cookies, restarted browser and tried again, same results.

Hey! I just got it to work using Chrome on my iPhone. Difference is, when I edit the post, the .jpg image doesn't show up; it shows as bbcode containing both the url and image tags. I had to edit the url tag with /Forums/PostLink/###### and then it saved correctly.

+0
Friday, February 17, 2017 4:27 PM

On your phone, you may get the lo-fi text editing experience, which cuts out the nice editor entirely. You can also set this in your profile, if you'd like, so it works that way on the desktop.

I'm wondering if you have any browser extensions or plugins or something interfering, because I don't have those issues on Chrome (Mac version).

+0
Sunday, February 19, 2017 2:44 PM

Maybe, but I don't have a whole lot of plugins or extensions, plus it does the same thing in Firefox. I'm using a relatively new PC, too, but it did the same thing on my old one. Not sure what the deal is (as Gonchar said, it's pretty random), but at least I have a workaround I guess.

+0
Friday, February 22, 2019 5:10 PM

Still having this issue, for what it's worth. Every time I make a new post in Chrome on my PC and want to link to an old post, I have to edit the post in Chrome for IOS.

A new fun thing I just discovered is that if I edit the post, then go in and edit the hyperlink and manually add the "Forums" bit, then PREVIEW the post, clicking on the link works like a charm. Then I save the post, click the link and get a 404.

+0
Friday, February 22, 2019 9:25 PM

Looking at it in preview is the same code as posting. There has gotta be something messing with your browser. At this point, TinyMCE has had a ton of new versions, and I haven't seen any big reports for it that describe this problem.

It's possible that you're a unicorn. If you want a plane you can screw around and experiment in an unlimited fashion, try here:

https://popforumsdev.azurewebsites.net/Forums

+0
Thursday, April 11, 2019 8:41 PM

@Vater: I see you messing around on the dev server and getting the weirdness there. Thank you for doing that. To be clear, just pasting in a link generally works, right? It's only when you highlight a word and put a link on it?

+0
Thursday, April 11, 2019 9:37 PM

Good news... I found a configuration switch for the editor that may fix the problem. I'll try to get a build out tonight and push it to CB.

+0
Friday, April 12, 2019 11:26 AM

Awesome! Yes, simply pasting a link works fine, it only seems to be weird when adding a hyperlink to existing text.

BTW, I meant to check out the dev server back when you posted it, but never got around to it. Thanks for the tip.

Last edited by Vater, Friday, April 12, 2019 11:28 AM
+0
Friday, April 12, 2019 11:35 AM

I figured out the way to debug it, without even posting (because it's an in-browser problem). If you link a few words, then move the cursor around, and back to the link, push the link button, you can see if it has mangled the URL you pasted in. I think it's solved now.

Last edited by Jeff, Friday, April 12, 2019 1:28 PM
+1Loading
Saturday, April 13, 2019 12:01 PM

I don't know if the problem I am experiencing is related to this particular topic, but...

Today I noticed that when I try to correct a misspelled word, underlined in red, when I right click, a little gray box appears with the a chin icon, the word "Link..." then a command symbol, then the letter k. It shows that instead of a list of correctly-spelled word choices.

OS X Yosemite 10.10.5
Firefox Quantum 66.0.3 (64-bit)

+0
Saturday, April 13, 2019 5:33 PM

Not sure what the deal is with that. Looks intentional and by design. You can do command-: to bring up the spelling dialog.

+0
Monday, April 15, 2019 2:30 AM

I never knew about a shortcut for a spelling dialog box. I tried bringing it up here and elsewhere and it doesn't work. Maybe it's a problem on my end. I did get a new keyboard recently. It's not Apple but is Apple compatible. That's probably the problem.

+0
Monday, April 15, 2019 12:16 PM

I'm having a problem with my 3d party spell checker too. When I hover over a misspelled word a "link" prompt appears instead of a suggested spelling.

+0

You must be logged in to post

POP Forums - ©2019, POP World Media, LLC
Loading...