KW and CP May 9 & 10

Associated parks:
None

Sunday, May 11, 2003 12:10 PM
I just got back from a weekend trip to KW and CP. I am really tired right now so I will make this quick. We got to Kennywood an hour before the park opened on Friday. It was pouring rain, thundering, and lightning. My sister and i went in to see how it was anyway. After about 30 minutes it was beautiful outside and the rain was done. We did all the coasters except for Lil' Phantom. I had no time to do all the flat ride. I did get on the Paratrooper though.

I left there and got to Cedar Point at 5:45.
I haven't been to CP since August 01' so I still had to fo WT. When we got there we got right in line for TTD. It looked awesome. We walked to the entrance and I was shocked. The line said 1 1/2 hours! We got in line. By 1 1/2 hours were were at the platform. We had to wait for the front. We did and the visuals are amazing. The launch was very, very strong. It is hard to explain it. After that we left.

At 7:30 we went to the SC entrance. We went under Magnun. We were the first ones there. We waited until 9 for them to let us in. (By the way, we stayed at Breakers Express. It was great, and I loved the Krispy Kreme machine! Buy, there was no DDR in the arcade. Just a broken Mocapigold Game.) Anyway, we saw them test at 9:45 It rolled back. By now I was worried. At nine they let us in and we ran to TTD! Not a very long run. I got there 10th and I wanted back. (Yesterday I had the blue train.) I walked up to the platform. I chatted with someone I was about to ride with for awhile. (My sister went up the right ramp I went left). Finally after tons of trains just clearing the hill I got first ride, purple train, back seat. They took us out then brough us back to the station. Then they took us back and we launched. Another amazing ride! I still prefer the front. The airtinme is the same. A little bit only. Also I don't know why they didn't start testing until 9:45 so it opened an hour late. Anyone know why?

Anyway Millennium Force was down all day. The red train was stuck about 250 feet up the whole day! I did WT once after being next in line and having it break down. Some other strange things happened that day but I am too tired to write them down. Thanks for reading.

------------------
-Sean Newman
*** This post was edited by SFgadvMAN 5/11/2003 6:09:48 PM ***

+0
Sunday, May 11, 2003 2:36 PM
How many trains were running on TTD?
+0
Sunday, May 11, 2003 2:51 PM
5 are now running. Yellow is still MIA

------------------
God bless Intamin, Company that I love. Stand beside her, and ride her, from the opening to the closing of the day.

+0
Sunday, May 11, 2003 3:27 PM
On the second day in the morning there were five. Then before it opened to the public they took it down to 4.

------------------
-Sean Newman

+0

You must be logged in to post

POP Forums - ©2018, POP World Media, LLC
Loading...