Great Adventure Opening Day 4/5/12

Thursday, April 5, 2012 5:00 PM

I just got back from Great Adventure and was disappointed about how my day went. It was a 1 Flag Day

I got to the entrance to the park around 10:40 and the line of cars was backed up to 537, and by the time I made it to the overpass, the cars were on 537 waiting to get into the park. It took over 30 minutes from the time I got to the entrance until I parked the car.

There are now metal detectors before you get to the ticket booths, so you have to wait for the metal detectors and then wait again at the entrance to get into the park.

I went to Nitro first, 2 trains were running and it was a 2 train wait. It was great to be riding Nitro again and the ride was awesome as always. I walked around for another ride and with so many cars still waiting to enter the park, I thought I had better go to some other rides rather than going for more rides on Nitro.

Skull Mountain was next, 1 train wait for the last row. The pumpkin at the final helix is now on some bales of Hay and the Skull Figure is still lit up, other than that the ride is dark with the tiki masks no longer lit up and the black light glow in the dark track had no lights on it so it wasn't showing.

I checked Green Lantern's line and it looked to be around an hour so I decided to come back later and walked over to Kingda Ka. It wasn't running and there was a small line outside the entrance but after a few minutes of waiting and nothing going on, I left.

The Saw Mill Log Flume was closed and there was all this stuff on the turntable like the ride was having some kind of work done and didn't look like it would be opening today.

The Skyway was broken down, Runaway Mine Train was having problems so I went to Bizarro. 2 trains were running and it was a 1 train wait. Unfortunately, the dispatches were the slowest I have ever seen at the ride. By the time the train I was on got to the final brake run and was waiting outside the station, the restraints on the other train hadn't even been checked yet. I decided against another ride and went back to Runaway Mine Train.

On one train they weren't loading the front 2 cars, on one train they weren't loading the last 2 cars. It was a 2 train wait but after I was seated in the train, they made everyone get out of the train because the ride was broken down again. I waited a few minutes, and the ride was still broken so I left again, saw the Skyway was closed and then went back to Kingda Ka because I saw it was running.

By the time I got to the entrance the ride had broken down again and they had only been able to launch 2 trains. After about 10 minutes, they opened the ride again and this time it launched 3 or 4 trains before breaking down yet again. They actually took the train ready to launch and reversed it to the other side of the station that isn't being used anymore. About 15 minutes later, the ride started again and I was able to ride. The coaster seemed rougher than I remembered and by the time I exited the ride, the line was past the entrance although no switchbacks were used.

I had seen the Skyway running again while walking from Kingda Ka but by the time I got to it, it had closed again. Runaway Mine Train was open with the line to the entrance with no switchbacks used. It took around 10 minutes to get to the station but when I was 3 trains away from boarding, it broke down again. They said it would be another minute but then said it would be longer so I left after wasting 25 minutes in line.

From Kingda Ka, I had seen Green Lantern's line was even longer than before and was ready to leave but I figured I would try to ride 1 more coaster. Blackbeard's had a long line, Skull Mountain looked to be around 20 minutes and Nitro was in the switchbacks. With 2 trains running, it was at least an hour. I saw The Dark Knight didn't have much of a line so decided to go there. It took forever to get into the pre-show room which I later found out was because the line after the pre-show was all backed up. It normally moves quickly but was crawling today and the entire wait took over 30 minutes.

The hologram billboards still aren't working and the Bat Signal wasn't working at the end of the ride (it showed a light but it wasn't the Bag Signal). On the way out of the park, I saw Batman's line was in the garden area.

I had enough since so many rides kept breaking down and the open rides had long lines. Exiting the park, I saw they switched to using the old metal detectors at the entrance to the park.

The lot was maybe 40% full but the park seemed crowded. I also noticed that candy bars from the vending machines went from $2.00 to $2.75! I thought $2.00 was a lot but the $2.75 didn't seem to stop people as I saw the vending machines being used.

I know it was opening day and things can go wrong but this was one of the worst visits I have had to the park. I hope to go again next week and have a better trip to the park.

+0
Friday, April 6, 2012 12:32 PM

I was there yesterday as well with my son and daghter, I would have to agree with YoshiFan. We arrived at 9:30am, were part of first group through the gates and headed straight back to Kingda Ka, should have been in second or third car, only to find out they were having "technical difficulties".

It really showed that it was the first day of operations. Overall most of the rides were short staffed and struggling to get into any kind of rythum. Rolling Thunder was only operating one side with 2 trains. Green Lantern was continually having trouble, seemed they ran more empty trains than full at times.

Once we got our season passes processed we went onto ride Bizzarro, Runaway Train, Tea Cups, Round Up, Skull Mountain, Batman, and finally made it back to KK to finish out the evening. Just as we were walking up to KK it had a rollback, freaked out the kids, it was our first time riding KK.

This is our first season with season passes, so I was not sure of the whole process. The staff that I did talk to were very helpful and informative. The overall staff experience was good, wish I could say the same for some of the guests.....hopefully we will make it down to SFAM this weekend to see how that goes.

+0

You must be logged in to post

POP Forums - ©2018, POP World Media, LLC
Loading...